Cloudflare outage
Incident Report for Project Duck
Resolved
Cloudflare is fully back online
Posted Jul 17, 2020 - 16:06 PDT
Monitoring
Cloudflare is down and currently recovering. Website and launcher (including quicklaunch) may be intermittently unavailable.
Posted Jul 17, 2020 - 15:07 PDT
This incident affected: Website and Launcher.